What’s Vulnerable › Vulnerabilities
CVE-2025-24860: Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer. Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions. This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer. Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Affected products
- Apache Software Foundation Apache Cassandra: from 4.0.0 before 4.0.16; from 4.1.0 before 4.1.8; from 5.0.0 before 5.0.3 — fixed in 4.0.16, 4.1.8, 5.0.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Cassandra 4.0.16, 4.1.8, 5.0.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/yjo5on4tf7s1r9qklc4byrz30b8vkm2d
- http://www.openwall.com/lists/oss-security/2025/02/03/3
- https://security.netapp.com/advisory/ntap-20250214-0005/
Get alerted when CVE-2025-24860 or the next vulnerability affects your stack