What’s Vulnerable › Vulnerabilities
CVE-2025-24928
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-121
Description
libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in xmlSnprintfElements in valid.c. To exploit this, DTD validation must occur for an untrusted document or untrusted DTD. NOTE: this is similar to CVE-2017-9047.
Affected products
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Hci Compute Node: all versions
- NetApp Manageability Software Development Kit: all versions
- NetApp ONTAP 9: 9
- NetApp Solidfire & Hci Management Node: all versions
- xmlsoft libxml2: before 2.12.10; from 2.13.0 before 2.13.6 — fixed in 2.12.10, 2.13.6
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.12.10, 2.13.6. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/847
- https://issues.oss-fuzz.com/issues/392687022
- https://lists.debian.org/debian-lts-announce/2025/02/msg00028.html
- https://security.netapp.com/advisory/ntap-20250321-0006/
Get alerted when CVE-2025-24928 or the next vulnerability affects your stack