What’s Vulnerable › Vulnerabilities
CVE-2025-24959: Environment Variable Injection for dotenv API in zx
- Severity: low (CVSS 1.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-03 · updated 2026-06-17
- Weakness: CWE-94
Description
zx is a tool for writing better scripts. An attacker with control over environment variable values can inject unintended environment variables into `process.env`. This can lead to arbitrary command execution or unexpected behavior in applications that rely on environment variables for security-sensitive operations. Applications that process untrusted input and pass it through `dotenv.stringify` are particularly vulnerable. This issue has been patched in version 8.3.2. Users should immediately upgrade to this version to mitigate the vulnerability. If upgrading is not feasible, users can mitigate the vulnerability by sanitizing user-controlled environment variable values before passing them to `dotenv.stringify`. Specifically, avoid using `"`, `'`, and backticks in values, or enforce strict validation of environment variables before usage.
Affected products
- Google zx: from 8.3.0, < 8.3.2
References
- https://github.com/google/zx/pull/1094
- https://github.com/google/zx/security/advisories/GHSA-qwp8-x4ff-5h87
Get alerted when CVE-2025-24959 or the next vulnerability affects your stack