What’s Vulnerable › Vulnerabilities
CVE-2025-24970: SslHandler doesn't correctly validate packets which can lead to native crash when using native SSLEngine
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-10 · updated 2026-06-17
- Weakness: CWE-20
Description
Netty, an asynchronous, event-driven network application framework, has a vulnerability starting in version 4.1.91.Final and prior to version 4.1.118.Final. When a special crafted packet is received via SslHandler it doesn't correctly handle validation of such a packet in all cases which can lead to a native crash. Version 4.1.118.Final contains a patch. As workaround its possible to either disable the usage of the native SSLEngine or change the code manually.
Affected products
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- OnCommand Insight: all versions
- netty: from 4.1.91 before 4.1.118 — fixed in 4.1.118
How to fix
Upgrade to a fixed version: netty 4.1.118. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/commit/87f40725155b2f89adfde68c7732f97c153676c4
- https://github.com/netty/netty/security/advisories/GHSA-4g8c-wm8x-jfhw
- https://security.netapp.com/advisory/ntap-20250221-0005/
- https://www.vicarius.io/vsociety/posts/cve-2025-24970-netty-vulnerability-detection
- https://www.vicarius.io/vsociety/posts/cve-2025-24970-netty-vulnerability-mitigation
- https://github.com/netty/netty/security/advisories/GHSA-4g8c-wm8x-jfhw
Get alerted when CVE-2025-24970 or the next vulnerability affects your stack