What’s Vulnerable › Vulnerabilities
CVE-2025-24972: Discourse may bypass user preference when adding users to chat groups
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-862
Description
Discourse is an open-source discussion platform. Prior to versions `3.3.4` on the `stable` branch and `3.4.0.beta5` on the `beta` branch, in specific circumstances, users could be added to group direct messages despite disabling direct messaging in their preferences. Versions `3.3.4` and `3.4.0.beta5` contain a patch for the issue. A workaround is available. If a user disables chat in their preferences then they cannot be added to new group chats.
Affected products
- discourse: before 3.3.4; before 3.4.0; 3.4.0-beta1, 3.4.0-beta2, 3.4.0-beta3, 3.4.0-beta4 — fixed in 3.3.4, 3.4.0
How to fix
Upgrade to a fixed version: discourse 3.3.4, 3.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24972 or the next vulnerability affects your stack