What’s Vulnerable › Vulnerabilities
CVE-2025-24974: DataEase Mysql JDBC Connection Parameters Not Being Verified Leads to Arbitrary File Read Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-13 · updated 2026-06-17
- Weakness: CWE-89
Description
DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.6, authenticated users can read and deserialize arbitrary files through the background JDBC connection. The vulnerability has been fixed in v2.10.6. No known workarounds are available.
Affected products
- dataease: before 2.10.6 — fixed in 2.10.6
How to fix
Upgrade to a fixed version: dataease 2.10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24974 or the next vulnerability affects your stack