What’s Vulnerable › Vulnerabilities
CVE-2025-24975: Firebird Non-Authorized Access to Encrypted Database Using Execute Statement on External
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-15 · updated 2026-06-17
- Weakness: CWE-754
Description
Firebird is a relational database. Prior to snapshot versions 4.0.6.3183, 5.0.2.1610, and 6.0.0.609, Firebird is vulnerable if ExtConnPoolSize is not set equal to 0. If connections stored in ExtConnPool are not verified for presence and suitability of the CryptCallback interface is used when created versus what is available could result in a segfault in the server process. Encrypted databases, accessed by execute statement on external, may be accessed later by an attachment missing a key to that database. In a case when execute statement are chained, segfault may happen. Additionally, the segfault may affect unencrypted databases. This issue has been patched in snapshot versions 4.0.6.3183, 5.0.2.1610, and 6.0.0.609 and point releases 4.0.6 and 5.0.2. A workaround for this issue involves setting ExtConnPoolSize equal to 0 in firebird.conf.
Affected products
- FirebirdSQL firebird: from 4.0.0 before 4.0.6; from 5.0.0 before 5.0.2 — fixed in 4.0.6, 5.0.2
How to fix
Upgrade to a fixed version: FirebirdSQL firebird 4.0.6, 5.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/FirebirdSQL/firebird/commit/658abd20449f72097fbbce57e8e6ae42ff837fb6
- https://github.com/FirebirdSQL/firebird/issues/8429
- https://github.com/FirebirdSQL/firebird/security/advisories/GHSA-fx9r-rj68-7p69
- https://www.vicarius.io/vsociety/posts/cve-2025-24975-detect-vulnerable-firebird
- https://www.vicarius.io/vsociety/posts/cve-2025-24975-mitigate-firebird-vulnerability
Get alerted when CVE-2025-24975 or the next vulnerability affects your stack