What’s Vulnerable › Vulnerabilities
CVE-2025-24977: OpenCTI has remote code execution and sensitive secrets exposed through web hook
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-05 · updated 2026-06-17
- Weakness: CWE-94
Description
OpenCTI is an open cyber threat intelligence (CTI) platform. Prior to version 6.4.11 any user with the capability `manage customizations` can execute commands on the underlying infrastructure where OpenCTI is hosted and can access internal server side secrets by misusing the web-hooks. Since the malicious user gets a root shell inside a container this opens up the the infrastructure environment for further attacks and exposures. Version 6.4.11 fixes the issue.
Affected products
- OpenCTI-Platform opencti: from 6.4.8 before 6.4.11 — fixed in 6.4.11
How to fix
Upgrade to a fixed version: OpenCTI-Platform opencti 6.4.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24977 or the next vulnerability affects your stack