What’s Vulnerable › Vulnerabilities
CVE-2025-2498: Insufficient Granularity of Access Control in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-13 · updated 2026-06-17
- Weakness: CWE-1220
Description
An improper access control in Gitlab EE affecting all versions from 12.0 prior to 18.0.6, 18.1 prior to 18.1.4, and 18.2 prior to 18.2.2 that under certain conditions could have allowed users to view assigned issues from restricted groups by bypassing IP restrictions.
Affected products
- GitLab: from 12.0.0 before 18.0.6; from 18.1.0 before 18.1.4; from 18.2.0 before 18.2.2 — fixed in 18.0.6, 18.1.4, 18.2.2
How to fix
Upgrade to a fixed version: GitLab 18.0.6, 18.1.4, 18.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2498 or the next vulnerability affects your stack