What’s Vulnerable › Vulnerabilities
CVE-2025-24980: Pimcore Admin Classic Bundle allows user enumeration
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-07 · updated 2026-06-17
- Weakness: CWE-204
Description
pimcore/admin-ui-classic-bundle provides a Backend UI for Pimcore. In affected versions an error message discloses existing accounts and leads to user enumeration on the target via "Forgot password" function. No generic error message has been implemented. This issue has been addressed in version 1.7.4 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- pimcore admin-ui-classic-bundle: before 1.7.4.1 — fixed in 1.7.4.1
How to fix
Upgrade to a fixed version: pimcore admin-ui-classic-bundle 1.7.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/admin-ui-classic-bundle/commit/96ae555578c3b4df368092d71e07a6c4ddf8fbe9
- https://github.com/pimcore/admin-ui-classic-bundle/pull/808
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-vr5f-php7-rg24
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-vr5f-php7-rg24
Get alerted when CVE-2025-24980 or the next vulnerability affects your stack