What’s Vulnerable › Vulnerabilities
CVE-2025-24986: Azure Promptflow Remote Code Execution Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-653
Description
Improper isolation or compartmentalization in Azure PromptFlow allows an unauthorized attacker to execute code over a network.
Affected products
- Microsoft Azure Promptflow Core: before 1.17.2 — fixed in 1.17.2
- Microsoft Azure Promptflow Tools: before 1.6.0 — fixed in 1.6.0
- Microsoft Azure promptflow-core: from 1.0.0 before 1.17.2 — fixed in 1.17.2
- Microsoft Azure promptflow-tools: from 1.0.0 before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Microsoft Azure Promptflow Core 1.17.2; Microsoft Azure Promptflow Tools 1.6.0; Microsoft Azure promptflow-core 1.17.2; Microsoft Azure promptflow-tools 1.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-24986 or the next vulnerability affects your stack