What’s Vulnerable › Vulnerabilities
CVE-2025-25004: PowerShell Elevation of Privilege Vulnerability
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-06-17
- Weakness: CWE-284
Description
Improper access control in Microsoft PowerShell allows an authorized attacker to elevate privileges locally.
Affected products
- Microsoft Powershell: from 7.4 before 7.4.13; from 7.5 before 7.5.4 — fixed in 7.4.13, 7.5.4
- Microsoft Windows 10 Version 1507: before 10.0.10240.21161 — fixed in 10.0.10240.21161
- Microsoft Windows 10 1607: before 10.0.14393.8519 — fixed in 10.0.14393.8519
- Microsoft Windows 10: before 10.0.17763.7919 — fixed in 10.0.17763.7919
- Microsoft Windows 10: before 10.0.19044.6456 — fixed in 10.0.19044.6456
- Microsoft Windows 10: before 10.0.19045.6456 — fixed in 10.0.19045.6456
- Microsoft Windows 11: before 10.0.22621.6060 — fixed in 10.0.22621.6060
- Microsoft Windows 11: through 10.0.22631.6060
- Microsoft Windows 11: before 10.0.26100.6899 — fixed in 10.0.26100.6899
- Microsoft Windows 11 25H2: before 10.0.26200.6899 — fixed in 10.0.26200.6899
- Microsoft Windows Server 2008: r2-sp1
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: through 10.0.14393.8519
- Microsoft Windows Server 2019: before 10.0.17763.7919 — fixed in 10.0.17763.7919
- Microsoft Windows Server 2022: before 10.0.20348.4294 — fixed in 10.0.20348.4294
- Microsoft Windows Server 2022, 23H2 Edition (Server Core installation): before 10.0.25398.1913 — fixed in 10.0.25398.1913
- Microsoft Windows Server 2025: through 10.0.26100.6899
- Microsoft PowerShell 7.4: from 7.4.0 before 7.4.13 — fixed in 7.4.13
- Microsoft PowerShell 7.5: from 7.5.0 before 7.5.4 — fixed in 7.5.4
- Microsoft Windows 10 Version 1507: from 10.0.10240.0 before 10.0.10240.21161 — fixed in 10.0.10240.21161
- Microsoft Windows 10 1607: from 10.0.14393.0 before 10.0.14393.8519 — fixed in 10.0.14393.8519
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.7919 — fixed in 10.0.17763.7919
- Microsoft Windows 10: from 10.0.19044.0 before 10.0.19044.6456 — fixed in 10.0.19044.6456
- Microsoft Windows 10: from 10.0.19045.0 before 10.0.19045.6456 — fixed in 10.0.19045.6456
- Microsoft Windows 11: from 10.0.22621.0 before 10.0.22621.6060 — fixed in 10.0.22621.6060
- Microsoft Windows 11 version 22H3: from 10.0.22631.0 before 10.0.22631.6060 — fixed in 10.0.22631.6060
- Microsoft Windows 11: from 10.0.22631.0 before 10.0.22631.6060 — fixed in 10.0.22631.6060
- Microsoft Windows 11: from 10.0.26100.0 before 10.0.26100.6899 — fixed in 10.0.26100.6899
- Microsoft Windows 11 25H2: from 10.0.26200.0 before 10.0.26200.6899 — fixed in 10.0.26200.6899
- Microsoft Windows Server 2008 R2 Service Pack 1: from 6.1.7601.0 before 6.1.7601.27974 — fixed in 6.1.7601.27974
How to fix
Upgrade to a fixed version: Microsoft Powershell 7.4.13, 7.5.4; Microsoft Windows 10 Version 1507 10.0.10240.21161; Microsoft Windows 10 1607 10.0.14393.8519; Microsoft Windows 10 10.0.17763.7919; Microsoft Windows 10 10.0.19044.6456; Microsoft Windows 10 10.0.19045.6456; Microsoft Windows 11 10.0.22621.6060; Microsoft Windows 11 10.0.26100.6899; Microsoft Windows 11 25H2 10.0.26200.6899; Microsoft Windows Server 2019 10.0.17763.7919; Microsoft Windows Server 2022 10.0.20348.4294; Microsoft Windows Server 2022, 23H2 Edition (Server Core installation) 10.0.25398.1913. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-25004 or the next vulnerability affects your stack