What’s Vulnerable › Vulnerabilities
CVE-2025-25013: Elastic Defend Insertion of Sensitive Information into Log Files
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-532
Description
Improper restriction of environment variables in Elastic Defend can lead to exposure of sensitive information such as API keys and tokens via automatic transmission of unfiltered environment variables to the stack.
Affected products
- Elastic Defend: from 8.0.0 before 8.17.3 — fixed in 8.17.3
How to fix
Upgrade to a fixed version: Elastic Defend 8.17.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-25013 or the next vulnerability affects your stack