What’s Vulnerable › Vulnerabilities
CVE-2025-25017: Kibana Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-10 · updated 2026-10-08
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation in Kibana can lead to Cross-Site Scripting (XSS)
Affected products
- Kibana: from 7.0.0 before 8.18.8; from 8.19.0 before 8.19.4; from 9.0.0 before 9.0.7; from 9.1.0 before 9.1.4 — fixed in 8.18.8, 8.19.4, 9.0.7, 9.1.4
How to fix
Upgrade to a fixed version: Kibana 8.18.8, 8.19.4, 9.0.7, 9.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-25017 or the next vulnerability affects your stack