What’s Vulnerable › Vulnerabilities

CVE-2025-25062

Description

An XSS issue was discovered in Backdrop CMS 1.28.x before 1.28.5 and 1.29.x before 1.29.3. It doesn't sufficiently isolate long text content when the CKEditor 5 rich text editor is used. This allows a potential attacker to craft specialized HTML and JavaScript that may be executed when an administrator attempts to edit a piece of content. This vulnerability is mitigated by the fact that an attacker must have the ability to create long text content (such as through the node or comment forms) and an administrator must edit (not view) the content that contains the malicious content. This problem only exists when using the CKEditor 5 module.

Affected products

How to fix

Upgrade to a fixed version: BackdropCMS Backdrop 1.28.5, 1.29.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-25062 or the next vulnerability affects your stack