What’s Vulnerable › Vulnerabilities

CVE-2025-25068: Bypassing MFA Enforcement on Plugin Endpoints

Description

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8, 10.5.x <= 10.5.0 fail to enforce MFA on plugin endpoints, which allows authenticated attackers to bypass MFA protections via API requests to plugin-specific routes.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.3.4, 10.4.3, 10.5.1, 9.11.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-25068 or the next vulnerability affects your stack