What’s Vulnerable › Vulnerabilities
CVE-2025-2515: Bluechi: privilege escalation in bluechi via unrestricted cross-node systemd dependencies
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-24 · updated 2026-10-07
- Weakness: CWE-863
Description
A vulnerability was found in BlueChi, a multi-node systemd service controller used in RHIVOS. This flaw allows a user with root privileges on a managed node (qm) to create or override systemd service unit files that affect the host node. This issue can lead to privilege escalation, unauthorized service execution, and potential system compromise.
Affected products
- Eclipse Foundation BlueChi: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Eclipse Foundation BlueChi 1.0.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-2515
- https://bugzilla.redhat.com/show_bug.cgi?id=2353313
- https://github.com/eclipse-bluechi/bluechi/commit/fe0d28301ce2bd45f0b1d8a98a94efef799fbc73#diff-64140c83db42a8888f346a40de293b80f79ebf7d75ce4137b22567e360bce607
- https://github.com/eclipse-bluechi/bluechi/issues/1069
- https://github.com/eclipse-bluechi/bluechi/pull/1073
Get alerted when CVE-2025-2515 or the next vulnerability affects your stack