What’s Vulnerable › Vulnerabilities
CVE-2025-25182: Stroom Authentication/Authorization Bypass when using AWS ALB
- Severity: critical (CVSS 9.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-290
Description
Stroom is a data processing, storage and analysis platform. A vulnerability exists starting in version 7.2-beta.53 and prior to versions 7.2.24, 7.3-beta.22, 7.4.4, and 7.5-beta.2 that allows authentication bypass to a Stroom system when configured with ALB and installed in a way that the application is accessible not through the ALB itself. This vulnerability may also allow for server-side request forgery which may lead to code execution or further privileges escalations when using the AWS metadata URL. This scenario assumes that Stroom must be configured to use ALB Authentication integration and the application is network accessible. The vulnerability has been fixed in versions 7.2.24, 7.3-beta.22, 7.4.4, and 7.5-beta.2.
Affected products
- stroom:stroom-app: from 7.2-beta.53, < 7.2.24; from 7.3-beta.1, < 7.3-beta.22; from 7.4-beta.1, < 7.4.4; = 7.5-beta.1
References
- https://github.com/gchq/stroom/pull/4320
- https://github.com/gchq/stroom/security/advisories/GHSA-x489-xx2m-vc43
Get alerted when CVE-2025-25182 or the next vulnerability affects your stack