What’s Vulnerable › Vulnerabilities
CVE-2025-25196: OpenFGA Authorization Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-19 · updated 2026-06-17
- Weakness: CWE-285
Description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA < v1.8.4 (Helm chart < openfga-0.2.22, docker < v.1.8.4) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users on OpenFGA v1.8.4 or previous, specifically under the following conditions are affected by this authorization bypass vulnerability: 1. Calling Check API or ListObjects with a model that has a relation directly assignable to both public access AND userset with the same type. 2. A type bound public access tuple is assigned to an object. 3. userset tuple is not assigned to the same object. and 4. Check request's user field is a userset that has the same type as the type bound public access tuple's user type. Users are advised to upgrade to v1.8.5 which is backwards compatible. There are no known workarounds for this vulnerability.
Affected products
- openfga Helm Charts: before 0.2.22 — fixed in 0.2.22
- openfga: before 1.8.5 — fixed in 1.8.5
How to fix
Upgrade to a fixed version: openfga Helm Charts 0.2.22; openfga 1.8.5. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/commit/0aee4f47e0c642de78831ceb27bb62b116f49588
- https://github.com/openfga/openfga/security/advisories/GHSA-g4v5-6f5p-m38j
Get alerted when CVE-2025-25196 or the next vulnerability affects your stack