What’s Vulnerable › Vulnerabilities

CVE-2025-25249: Fortinet Multiple Products Heap-based Buffer Overflow Vulnerability

Description

A heap-based buffer overflow vulnerability in Fortinet FortiOS 7.6.0 through 7.6.3, FortiOS 7.4.0 through 7.4.8, FortiOS 7.2.0 through 7.2.11, FortiOS 7.0.0 through 7.0.17, FortiOS 6.4 all versions, FortiSwitchManager 7.2.0 through 7.2.6, FortiSwitchManager 7.0.0 through 7.0.5 allows attacker to execute unauthorized code or commands via specially crafted packets

Summary

CVE-2025-25249 is a critical (CVSS 9.8) heap-based buffer overflow in Fortinet FortiOS and FortiSwitchManager that lets an attacker execute unauthorized code or commands via specially crafted packets. It affects FortiOS 6.4 (all versions), 7.0.0-7.0.17, 7.2.0-7.2.11, 7.4.0-7.4.8 and 7.6.0-7.6.3, plus FortiSwitchManager 7.0.0-7.0.5 and 7.2.0-7.2.6; FortiSASE and Siemens Ruggedcom Ape1808 firmware are also listed. The flaw is in CISA's Known Exploited Vulnerabilities catalog with active exploitation and a public exploit or detection template exists. Upgrade to FortiOS 7.0.18, 7.2.12, 7.4.9 or 7.6.4, or FortiSwitchManager 7.0.6 or 7.2.7, and apply vendor mitigations per CISA BOD 26-04 guidance.

تُعدّ CVE-2025-25249 ثغرة تجاوز سعة المخزن المؤقت في الكومة (heap-based buffer overflow) خطيرة بتقييم CVSS 9.8 في منتجات Fortinet FortiOS وFortiSwitchManager، وتتيح للمهاجم تنفيذ تعليمات برمجية أو أوامر غير مصرّح بها عبر حزم مُصمَّمة خصيصًا. تشمل الإصدارات المتأثرة FortiOS 6.4 بجميع إصداراته، و7.0.0 حتى 7.0.17، و7.2.0 حتى 7.2.11، و7.4.0 حتى 7.4.8، و7.6.0 حتى 7.6.3، إضافة إلى FortiSwitchManager 7.0.0 حتى 7.0.5 و7.2.0 حتى 7.2.6، كما تظهر FortiSASE وبرنامج Siemens Ruggedcom Ape1808 ضمن المنتجات المتأثرة. الثغرة مدرجة في كتالوج CISA للثغرات المعروفة الاستغلال مع استغلال نشط، ويتوفر استغلال عام أو قالب كشف. يُنصح بالترقية إلى FortiOS 7.0.18 أو 7.2.12 أو 7.4.9 أو 7.6.4، وإلى FortiSwitchManager 7.0.6 أو 7.2.7، وتطبيق تخفيفات المورّد وفق إرشادات CISA BOD 26-04.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.0.18, 7.2.12, 7.4.9, 7.6.4; Fortinet FortiSwitchManager 7.0.6, 7.2.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-25249 or the next vulnerability affects your stack