What’s Vulnerable › Vulnerabilities

CVE-2025-2527: Improper access control to group information

Description

Mattermost versions 10.5.x <= 10.5.2, 9.11.x <= 9.11.11 failed to properly verify a user's permissions when accessing groups, which allows an attacker to view group information via an API request.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.3, 9.11.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2527 or the next vulnerability affects your stack