What’s Vulnerable › Vulnerabilities

CVE-2025-25279: Arbitrary file read in Mattermost Boards via import & export board archive

Description

Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to properly validate board blocks when importing boards which allows an attacker could read any arbitrary file on the system via importing and exporting a specially crafted import archive in Boards.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.2.3, 10.3.3, 10.4.2, 9.11.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-25279 or the next vulnerability affects your stack