What’s Vulnerable › Vulnerabilities
CVE-2025-2528
- Severity: low (CVSS 3.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper authorization in application password policy in Devolutions Remote Desktop Manager on Windows allows an authenticated user to use a configuration different from the one mandated by the system administrators. This issue affects Remote Desktop Manager versions from 2025.1.24 through 2025.1.25, and all versions up to 2024.3.29.
Affected products
- Devolutions Remote Desktop Manager: before 2024.3.31.0; from 2025.1.24.0 before 2025.1.26.0 — fixed in 2024.3.31.0, 2025.1.26.0
How to fix
Upgrade to a fixed version: Devolutions Remote Desktop Manager 2024.3.31.0, 2025.1.26.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2528 or the next vulnerability affects your stack