What’s Vulnerable › Vulnerabilities
CVE-2025-25291: ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-347
Description
ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. An authentication bypass vulnerability was found in ruby-saml prior to versions 1.12.4 and 1.18.0 due to a parser differential. ReXML and Nokogiri parse XML differently; the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. This issue may lead to authentication bypass. Versions 1.12.4 and 1.18.0 fix the issue.
Affected products
- NetApp StorageGRID: all versions
- OmniAuth OmnitAuth-SAML: before 1.10.6; from 2.0.0 before 2.1.3; from 2.2.0 before 2.2.3 — fixed in 1.10.6, 2.1.3, 2.2.3
- SAML-Toolkits ruby-saml: before 1.12.4; from 1.13.0 before 1.18.0 — fixed in 1.12.4, 1.18.0
- Rubygems Ruby-Saml: before 1.12.4; from 1.13.0 before 1.18.0; 0.0.5, 0.0.6, 0.0.7, 0.0.8, 0.2.1, 0.2.2 (+80) — fixed in 1.12.4, 1.18.0
How to fix
Upgrade to a fixed version: OmniAuth OmnitAuth-SAML 1.10.6, 2.1.3, 2.2.3; SAML-Toolkits ruby-saml 1.12.4, 1.18.0; Rubygems Ruby-Saml 1.12.4, 1.18.0. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2025/03/12/patch-release-gitlab-17-9-2-released
- https://github.blog/security/sign-in-as-anyone-bypassing-saml-sso-authentication-with-parser-differentials
- https://github.com/SAML-Toolkits/ruby-saml/commit/e76c5b36bac40aedbf1ba7ffaaf495be63328cd9
- https://github.com/SAML-Toolkits/ruby-saml/commit/e9c1cdbd0f9afa467b585de279db0cbd0fb8ae97
- https://github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.12.4
- https://github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.18.0
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-4vc4-m8qh-g8jm
- https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-hw46-3hmr-x9xv
- https://portswigger.net/research/saml-roulette-the-hacker-always-wins
- https://securitylab.github.com/advisories/GHSL-2024-329_GHSL-2024-330_ruby-saml
- https://lists.debian.org/debian-lts-announce/2025/04/msg00011.html
- https://news.ycombinator.com/item?id=43374519
Get alerted when CVE-2025-25291 or the next vulnerability affects your stack