What’s Vulnerable › Vulnerabilities

CVE-2025-25292: Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential)

Description

ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. An authentication bypass vulnerability was found in ruby-saml prior to versions 1.12.4 and 1.18.0 due to a parser differential. ReXML and Nokogiri parse XML differently, the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. This issue may lead to authentication bypass. Versions 1.12.4 and 1.18.0 contain a patch for the issue.

Affected products

How to fix

Upgrade to a fixed version: OmniAuth OmnitAuth-SAML 1.10.6, 2.1.3, 2.2.3; SAML-Toolkits ruby-saml 1.12.4, 1.18.0; Rubygems Ruby-Saml 1.18.0, 1.12.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-25292 or the next vulnerability affects your stack