What’s Vulnerable › Vulnerabilities

CVE-2025-25293: ruby-saml vulnerable to Remote Denial of Service (DoS) with compressed SAML responses

Description

ruby-saml provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. Prior to versions 1.12.4 and 1.18.0, ruby-saml is susceptible to remote Denial of Service (DoS) with compressed SAML responses. ruby-saml uses zlib to decompress SAML responses in case they're compressed. It is possible to bypass the message size check with a compressed assertion since the message size is checked before inflation and not after. This issue may lead to remote Denial of Service (DoS). Versions 1.12.4 and 1.18.0 fix the issue.

Affected products

How to fix

Upgrade to a fixed version: OmniAuth OmnitAuth-SAML 1.10.6, 2.1.3, 2.2.3; SAML-Toolkits ruby-saml 1.12.4, 1.18.0; Rubygems Ruby-Saml 1.12.4, 1.18.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-25293 or the next vulnerability affects your stack