What’s Vulnerable › Vulnerabilities
CVE-2025-25500
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-18 · updated 2026-06-17
- Weakness: CWE-284
Description
An issue in CosmWasm prior to v2.2.0 allows attackers to bypass capability restrictions in blockchains by exploiting a lack of runtime capability validation. This allows attackers to deploy a contract without capability enforcement, and execute unauthorized actions on the blockchain.
Affected products
- Cosmwasm: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: Cosmwasm 2.2.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/H3T76/8096a6ff9410f3a6d9a25db1a68ae657#file-cve-2025-25500
- https://gist.github.com/H3T76/8096a6ff9410f3a6d9a25db1a68ae657#file-cve-2025-25500
Get alerted when CVE-2025-25500 or the next vulnerability affects your stack