What’s Vulnerable › Vulnerabilities
CVE-2025-2561: Ninja Forms < 3.10.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ninja Forms WordPress plugin before 3.10.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.10.1 — fixed in 3.10.1
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.10.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2561 or the next vulnerability affects your stack