What’s Vulnerable › Vulnerabilities

CVE-2025-2571: Google OAuth Authentication Bypass for Converted Bot Accounts

Description

Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to clear Google OAuth credentials when converting user accounts to bot accounts, allowing attackers to gain unauthorized access to bot accounts via the Google OAuth signup flow.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.4, 10.6.3, 10.7.1, 9.11.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2571 or the next vulnerability affects your stack