What’s Vulnerable › Vulnerabilities
CVE-2025-2594: User Registration & Membership < 4.1.3 - Authentication Bypass
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-22 · updated 2026-06-17
Description
The User Registration & Membership WordPress plugin before 4.1.3 does not properly validate data in an AJAX action when the Membership Addon is enabled, allowing attackers to authenticate as any user, including administrators, by simply using the target account's user ID.
Affected products
- User Registration & Membership: before 4.1.3; before 5.1.3 — fixed in 4.1.3, 5.1.3
How to fix
Upgrade to a fixed version: User Registration & Membership 4.1.3, 5.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2594 or the next vulnerability affects your stack