What’s Vulnerable › Vulnerabilities
CVE-2025-25977
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-10 · updated 2026-06-17
- Weakness: CWE-1321
Description
An issue in canvg v.4.0.2 allows an attacker to execute arbitrary code via the Constructor of the class StyleElement.
Affected products
- Canvg: before 3.0.11; from 4.0.0 before 4.0.3 — fixed in 3.0.11, 4.0.3
How to fix
Upgrade to a fixed version: Canvg 3.0.11, 4.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-25977 or the next vulnerability affects your stack