What’s Vulnerable › Vulnerabilities
CVE-2025-2598: AWS CDK CLI prints AWS credentials retrieved by custom credential plugins
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-21 · updated 2026-06-17
- Weakness: CWE-497
Description
When the AWS Cloud Development Kit (AWS CDK) Command Line Interface (AWS CDK CLI) is used with a credential plugin which returns an expiration property with the retrieved AWS credentials, the credentials are printed to the console output. To mitigate this issue, users should upgrade to version 2.178.2 or later and ensure any forked or derivative code is patched to incorporate the new fixes.
Affected products
- aws-cdk: from 2.172.0 before 2.178.2 — fixed in 2.178.2
How to fix
Upgrade to a fixed version: aws-cdk 2.178.2. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/AWS-2025-005/
- https://github.com/aws/aws-cdk/releases/tag/v2.178.2
- https://github.com/aws/aws-cdk/security/advisories/GHSA-v63m-x9r9-8gqp
Get alerted when CVE-2025-2598 or the next vulnerability affects your stack