What’s Vulnerable › Vulnerabilities

CVE-2025-2614: Allocation of Resources Without Limits or Throttling in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 11.6 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed an authenticated user to cause a denial of service condition by creating specially crafted content that consumes excessive server resources when processed.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.0.6, 18.1.4, 18.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2614 or the next vulnerability affects your stack