What’s Vulnerable › Vulnerabilities

CVE-2025-2615: Insertion of Sensitive Information Into Sent Data in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.7 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2, that could have allowed a blocked user to access sensitive information by establishing GraphQL subscriptions through WebSocket connections.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.3.6, 18.4.4, 18.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2615 or the next vulnerability affects your stack