What’s Vulnerable › Vulnerabilities
CVE-2025-26260
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-94
Description
Plenti <= 0.7.16 is vulnerable to code execution. Users uploading '.svelte' files with the /postLocal endpoint can define the file name as javascript codes. The server executes the uploaded file name in host, and cause code execution.
Affected products
- plentico plenti: before 0.7.17 — fixed in 0.7.17
How to fix
Upgrade to a fixed version: plentico plenti 0.7.17. Check the vendor advisory for mitigations.
References
- https://ahmetakan.com/2025/02/14/cve-2025-26260/
- https://github.com/ahmetak4n/vulnerability-playground/tree/main/vulnerability-research/CVE-2025-26260
- https://github.com/plentico/plenti/releases/tag/v0.7.17
- https://github.com/plentico/plenti/security/advisories/GHSA-mj4v-hp69-27x5
- https://github.com/plentico/plenti/security/advisories/GHSA-mj4v-hp69-27x5
Get alerted when CVE-2025-26260 or the next vulnerability affects your stack