What’s Vulnerable › Vulnerabilities
CVE-2025-26268
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-17 · updated 2026-06-17
- Weakness: CWE-392
Description
DragonflyDB Dragonfly before 1.27.0 allows authenticated users to cause a denial of service (daemon crash) via a crafted Redis command. The validity of the scan cursor was not checked.
Affected products
- dragonflydb dragonfly: before 1.27.0 — fixed in 1.27.0
How to fix
Upgrade to a fixed version: dragonflydb dragonfly 1.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/dragonflydb/dragonfly/commit/d1fac0f912edb323a2bdd6404c518cda21eac243
- https://github.com/dragonflydb/dragonfly/compare/v1.26.4...v1.27.0
- https://github.com/dragonflydb/dragonfly/issues/4466
- https://github.com/dragonflydb/dragonfly/issues/4466
Get alerted when CVE-2025-26268 or the next vulnerability affects your stack