What’s Vulnerable › Vulnerabilities
CVE-2025-26413: Apache Kvrocks: The server was crashed by the negative offset
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Kvrocks. The SETRANGE command didn't check if the `offset` input is a positive integer and use it as an index of a string. So it will cause the server to crash due to its index is out of range. This issue affects Apache Kvrocks: through 2.11.1. Users are recommended to upgrade to version 2.12.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kvrocks: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kvrocks 2.12.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/388743qrr8yq8qm0go8tls6rf1kog8dw
- http://www.openwall.com/lists/oss-security/2025/04/22/1
Get alerted when CVE-2025-26413 or the next vulnerability affects your stack