What’s Vulnerable › Vulnerabilities
CVE-2025-26467: Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-25 · updated 2026-06-17
- Weakness: CWE-267
Description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected. Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.
Affected products
- Apache Software Foundation Apache Cassandra: from 3.0.0 before 3.0.31; from 3.11.0 before 3.11.18; from 4.0.0 before 4.0.17; from 4.1.0 before 4.1.8; from 5.0.0 before 5.0.3 — fixed in 3.0.31, 3.11.18, 4.0.17, 4.1.8, 5.0.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Cassandra 3.0.31, 3.11.18, 4.0.17, 4.1.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-26467 or the next vulnerability affects your stack