What’s Vulnerable › Vulnerabilities
CVE-2025-26477
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-17 · updated 2026-06-17
- Weakness: CWE-20
Description
Dell ECS version 3.8.1.4 and prior contain an Improper Input Validation vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Code execution.
Affected products
- EMC Elastic Cloud Storage all versions prior to 3.1: through 3.8.1.4
- Dell ObjectScale: before 4.0.0.0 — fixed in 4.0.0.0
How to fix
Upgrade to a fixed version: Dell ObjectScale 4.0.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-26477 or the next vulnerability affects your stack