What’s Vulnerable › Vulnerabilities
CVE-2025-26482
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-25 · updated 2026-06-17
- Weakness: CWE-1258
Description
Dell PowerEdge Server BIOS and Dell iDRAC9, all versions, contains an Information Disclosure vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to Information Disclosure.
Affected products
- Dell Dss 8440 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Emc Nx440 Firmware: before 2.18.0 — fixed in 2.18.0
- Dell Emc Storage Nx3240 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Emc Storage Nx3340 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Emc Xc Core 6420 System Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Emc Xc Core Xc450 Firmware: before 1.16.2 — fixed in 1.16.2
- Dell Emc Xc Core Xc640 System Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Emc Xc Core Xc650 Firmware: before 1.16.2 — fixed in 1.16.2
- Dell Emc Xc Core Xc6520 Firmware: before 1.16.2 — fixed in 1.16.2
- Dell Emc Xc Core Xc740Xd2 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Emc Xc Core Xc740Xd System Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Emc Xc Core Xc750 Firmware: before 1.16.2 — fixed in 1.16.2
- Dell Emc Xc Core Xc750Xa Firmware: before 1.16.2 — fixed in 1.16.2
- Dell Emc Xc Core Xc7525 Firmware: before 2.18.1 — fixed in 2.18.1
- Dell Emc Xc Core Xc940 System Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Emc Xc Core Xcxr2 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell EMC iDRAC: before 7.00.00.181; before 7.20.10.50 — fixed in 7.00.00.181, 7.20.10.50
- Dell Poweredge C4140 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Poweredge C6420 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Poweredge C6520 Firmware: before 1.16.2 — fixed in 1.16.2
- Dell Poweredge C6525 Firmware: before 2.18.1 — fixed in 2.18.1
- Dell Poweredge C6615 Firmware: before 1.6.2 — fixed in 1.6.2
- Dell Poweredge C6620 Firmware: before 2.5.4 — fixed in 2.5.4
- Dell Poweredge Fc640 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Poweredge Hs5610 Firmware: before 2.5.4 — fixed in 2.5.4
- Dell Poweredge Hs5620 Firmware: before 2.5.4 — fixed in 2.5.4
- Dell Poweredge M640 Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Poweredge Mx740C Firmware: before 2.23.0 — fixed in 2.23.0
- Dell Poweredge Mx750C Firmware: before 1.16.2 — fixed in 1.16.2
- Dell Poweredge Mx760C Firmware: before 2.5.4 — fixed in 2.5.4
How to fix
Upgrade to a fixed version: Dell Dss 8440 Firmware 2.23.0; Dell Emc Nx440 Firmware 2.18.0; Dell Emc Storage Nx3240 Firmware 2.23.0; Dell Emc Storage Nx3340 Firmware 2.23.0; Dell Emc Xc Core 6420 System Firmware 2.23.0; Dell Emc Xc Core Xc450 Firmware 1.16.2; Dell Emc Xc Core Xc640 System Firmware 2.23.0; Dell Emc Xc Core Xc650 Firmware 1.16.2; Dell Emc Xc Core Xc6520 Firmware 1.16.2; Dell Emc Xc Core Xc740Xd2 Firmware 2.23.0; Dell Emc Xc Core Xc740Xd System Firmware 2.23.0; Dell Emc Xc Core Xc750 Firmware 1.16.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-26482 or the next vulnerability affects your stack