What’s Vulnerable › Vulnerabilities
CVE-2025-26514: CVE-2025-26514 Reflected Cross-Site Scripting Vulnerability in StorageGRID (formerly StorageGRID Webscale)
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
StorageGRID (formerly StorageGRID Webscale) versions prior to 11.8.0.15 and 11.9.0.8 are susceptible to a Reflected Cross-Site Scripting vulnerability. Successful exploit could allow an attacker to view or modify configuration settings or add or modify user accounts but requires the attacker to know specific information about the target instance and then trick a privileged user into clicking a specially crafted link.
Affected products
- NetApp StorageGRID: before 11.8.0.15; from 11.9.0 before 11.9.0.8 — fixed in 11.8.0.15, 11.9.0.8
How to fix
Upgrade to a fixed version: NetApp StorageGRID 11.8.0.15, 11.9.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-26514 or the next vulnerability affects your stack