What’s Vulnerable › Vulnerabilities

CVE-2025-26519

Description

musl libc 0.9.13 through 1.2.5 before 1.2.6 has an out-of-bounds write vulnerability when an attacker can trigger iconv conversion of untrusted EUC-KR text to UTF-8.

Affected products

How to fix

Upgrade to a fixed version: musl-libc musl 1.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-26519 or the next vulnerability affects your stack