What’s Vulnerable › Vulnerabilities
CVE-2025-26525: Arbitrary file read risk through pdfTeX
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-24 · updated 2026-06-17
- Weakness: CWE-552
Description
Insufficient sanitizing in the TeX notation filter resulted in an arbitrary file read risk on sites where pdfTeX is available (such as those with TeX Live installed).
Affected products
- Moodle: from 4.1.0 before 4.1.16; from 4.3.0 before 4.3.10; from 4.4.0 before 4.4.6; from 4.5.0 before 4.5.2 — fixed in 4.1.16, 4.3.10, 4.4.6, 4.5.2
How to fix
Upgrade to a fixed version: Moodle 4.1.16, 4.3.10, 4.4.6, 4.5.2. Check the vendor advisory for mitigations.
References
- https://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-84136
- https://moodle.org/mod/forum/discuss.php?d=466141
Get alerted when CVE-2025-26525 or the next vulnerability affects your stack