What’s Vulnerable › Vulnerabilities
CVE-2025-26533: SQL injection risk in course search module list filter
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-24 · updated 2026-06-17
- Weakness: CWE-89
Description
An SQL injection risk was identified in the module list filter within course search.
Affected products
- Moodle: from 4.1.0 before 4.1.16; from 4.3.0 before 4.3.10; from 4.4.0 before 4.4.6; from 4.5.0 before 4.5.2 — fixed in 4.1.16, 4.3.10, 4.4.6, 4.5.2
How to fix
Upgrade to a fixed version: Moodle 4.1.16, 4.3.10, 4.4.6, 4.5.2. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-84271
- https://moodle.org/mod/forum/discuss.php?d=466150
Get alerted when CVE-2025-26533 or the next vulnerability affects your stack