What’s Vulnerable › Vulnerabilities

CVE-2025-26619: Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`

Description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.

Affected products

How to fix

Upgrade to a fixed version: Vega-Functions Project Vega-Functions 5.16.0; vega 5.31.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-26619 or the next vulnerability affects your stack