What’s Vulnerable › Vulnerabilities
CVE-2025-26623: Use After Free in Exiv2
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-416
Description
Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. A heap buffer overflow was found in Exiv2 versions v0.28.0 to v0.28.4. Versions prior to v0.28.0, such as v0.27.7, are **not** affected. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fixiso`. The bug is fixed in version v0.28.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- exiv2: from 0.28.0 before 0.28.5 — fixed in 0.28.5
How to fix
Upgrade to a fixed version: exiv2 0.28.5. Check the vendor advisory for mitigations.
References
- https://github.com/Exiv2/exiv2/issues/3168
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-38h4-fx85-qcx7
Get alerted when CVE-2025-26623 or the next vulnerability affects your stack