What’s Vulnerable › Vulnerabilities
CVE-2025-26627: Azure Arc Installer Elevation of Privilege Vulnerability
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-77
Description
Improper neutralization of special elements used in a command ('command injection') in Azure Arc allows an authorized attacker to elevate privileges locally.
Affected products
- Microsoft Azure ARC: before 1.0.10 — fixed in 1.0.10
- Microsoft Azure ARC: from 1.0.0 before 1.0.10 — fixed in 1.0.10
How to fix
Upgrade to a fixed version: Microsoft Azure ARC 1.0.10; Microsoft Azure ARC 1.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-26627 or the next vulnerability affects your stack