What’s Vulnerable › Vulnerabilities
CVE-2025-26699
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-06 · updated 2026-06-17
- Weakness: CWE-770
Description
An issue was discovered in Django 5.1 before 5.1.7, 5.0 before 5.0.13, and 4.2 before 4.2.20. The django.utils.text.wrap() method and wordwrap template filter are subject to a potential denial-of-service attack when used with very long strings.
Affected products
- Debian Linux: 11.0
- Django: from 4.2 before 4.2.20; from 5.0 before 5.0.13; from 5.1 before 5.1.7 — fixed in 4.2.20, 5.0.13, 5.1.7
How to fix
Upgrade to a fixed version: Django 4.2.20, 5.0.13, 5.1.7. Check the vendor advisory for mitigations.
References
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/g/django-announce
- https://www.djangoproject.com/weblog/2025/mar/06/security-releases/
- http://www.openwall.com/lists/oss-security/2025/03/06/12
- https://lists.debian.org/debian-lts-announce/2025/03/msg00012.html
Get alerted when CVE-2025-26699 or the next vulnerability affects your stack