What’s Vulnerable › Vulnerabilities

CVE-2025-26803

Description

The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.

Affected products

How to fix

Upgrade to a fixed version: Phusion Passenger 6.0.26. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-26803 or the next vulnerability affects your stack