What’s Vulnerable › Vulnerabilities
CVE-2025-2685: TablePress – Tables in WordPress made easy <= 3.0.4 - Authenticated (Author+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The TablePress – Tables in WordPress made easy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘table-name’ parameter in all versions up to, and including, 3.0.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- tobiasbg TablePress – Tables in WordPress made easy: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: tobiasbg TablePress – Tables in WordPress made easy 3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/tablepress/trunk/views/class-all-tables-list-table.php#L242
- https://plugins.trac.wordpress.org/changeset/3261229/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e285849f-886e-49ba-bb43-8c67655fe239?source=cve
Get alerted when CVE-2025-2685 or the next vulnerability affects your stack